前のパートに戻る 完了して次のパートへ  

  0-3 Laravelの環境構築(Cloud9)

Webアプリケーションを開発するための環境を構築します。

環境構築する環境はCloud9になります。

Cloud9とは、クラウド上でアプリケーション開発が出来るサービスです。PCに依存することなく開発環境をできます。各人が好きなPCを使うと教材のとおりにしても動かないということがあるのでそういったトラブルをなくすためにも本教材ではこちらのサービスを利用します。

Cloud9のアカウントをお持ちでない方は下記よりアカウントを作成してワークスペースの作成まで行って下さい。

Cloud9のURLはコチラ

Cloud9でのアカウントの作り方は以下のページを参考にして下さい。

Cloud9でのアカウントの作り方

アカウントを作る際、クレジットカードの登録が必要になりますがお持ちでない方はVプリカなどを利用すると良いでしょう。審査不要ですぐ作れます。

Vプリカ

Laravel環境を構築する


Laravelが動く環境を構築するには下記が必要となります。

  • MySQLのバージョンアップ(ver5.5 -> ver.5.7)
  • MySQLはVer.5.7以上とする必要があります。
  • デフォルトだとCloud9のMySQLのバージョンは5.5系になっているので5.7へバージョンアップさせる必要があります。
  • PHPのバージョンアップ(ver5.X -> ver.7)
  • Laravelを使うにはPHPのバージョンは7以上である必要があります。
  • デフォルトだとCloud9のPHPのバージョンは5.X系になっているので7.2へバージョンアップさせる必要があります。
  • composerのインストール
  • PHPのパッケージを管理するためcomposerというツールをインストールします。
  • Laravel5.5のインストール
  • composerを使ってLaravel5.5をインストールします。


現状のバージョン確認


PHPのバージョン確認

PHPの現在のバージョンを下記コマンドで確認してください。

$ php -v

下記のように表示されPHPのバージョンが5.6であることが確認できます。

PHP 5.6.40 (cli) (built: Mar  8 2019 18:17:39)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with Xdebug v2.5.5, Copyright (c) 2002-2017, by Derick Rethans


MySQLのバージョン確認

MySQLの現在のバージョンを下記コマンドで確認してください。

$ mysql --version

下記のように表示されMySQLのバージョンが5.5であることが確認できます。

mysql  Ver 14.14 Distrib 5.5.62, for Linux (x86_64) using readline 5.1


インストール


Laravel用の環境を構築するためのコマンドは非常に長いのでコマンドの入力間違いなどを防ぐため、一発で環境を構築するためのシェルスクリプトを用意しました。シェルスクリプトとは、簡単に言うとシェルへのコマンドを集めたプログラムのことです。

参考) シェル(shell)とは

「シェル」と「シェルスクリプト」の違い

下記のコマンドを実行してください。

$ sh -c "$(curl -fsSL https://gist.githubusercontent.com/MisterTeacher/e680ee45d468aa5e33c7f3d14175a1ca/raw/7d5ea114daf01b2ed1aa5ee62427f60574359976/cloud9-laravel-installer.sh)"

どのようなコマンドが実行されているかは上記シェルスクリプトのURLを開けば内容が見れるので気になる人は確認してみてくださいね。

再度、バージョン確認


PHPが正しくバージョンアップされたか確認するため、下記のコマンドを実行してください。

$ php -v

PHPのバージョンを確認すると下記の通りバージョンが7.2になっていることを確認できます。

PHP 7.2.16 (cli) (built: Mar  8 2019 18:56:55) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.2.16, Copyright (c) 1999-2018, by Zend Technologies
    with Xdebug v2.6.1, Copyright (c) 2002-2018, by Derick Rethans

MySQLが正しくバージョンアップされたか確認するため、下記のコマンドを実行してください。

$ mysql --version

MySQLのバージョンを確認すると下記の通りバージョンが5.7になっていることを確認できます。

mysql  Ver 14.14 Distrib 5.7.25, for Linux (x86_64) using  EditLine wrapper

以上で環境構築は完了です。万が一失敗したらCloud9のワークスペースを削除して再度ワークスペースを作成したあとに手順を最初からやり直してみてください。

お疲れ様でした。

議論

0 質問

このコースの評価は?